Knowledge Drop

Why can't I see my explore in the Explore drop-down menu?

  • 7 July 2021
  • 3 replies
  • 1235 views

Last tested: Aug 31, 2020
 

First confirm that the Explore has been saved and then refresh the page to see if the explore is populating in the Explore dropdown.

If the explore still isn't showing in the Explore menu, check if:

  • The extension: required parameter is defined in the Explore. An Explore with extension: required is not visible to users on its own; it is intended only to act as a starting point to be extended by other Explores (documentation).
  • The required_access_grants parameter is used on the Explore. If this parameter is used and a user doesn't have the necessary corresponding user attribute values, they won't be able to see the Explore in the dropdown menu (documentation).
  • If the Explore is extending an Explore, check whether the base/extended Explore has hidden: yes defined.

There is also a known issue in which if there is more than one model with the same name, the explore menu will sometimes show the explores from the unconfigured model instead of the explores from the configured model, even though the links will take you to the explores from the configured model. Check the Manage Projects page to see if there is another model with the same name in a different project.

 

This content is subject to limited support.                

 

 


3 replies

Userlevel 2

Also, explores may stay invisible is there is some incorrect syntax. For example, I had explore wrapped in the brackets like this  {.  explore: bla {} …. } - and it was not appearing anywhere

We can also check if the role has the explore permission, that can also cause this behavior. 
https://docs.looker.com/admin-options/settings/roles#explore

An Explore may also not display if it is based on a Model not included in the Model Set for that users Role.

Reply