Knowledge Drop

Why can't I "hide no's from visualization" in a table calc?

  • 5 April 2021
  • 0 replies
  • 534 views

Userlevel 5

Last tested: Sep 11, 2019
 

Double check to see if the Yes and No values have quotes wrapped around them!

Note that if(${field_name} > x, "Yes", "No") is not the same as if(${field_name} > x, yes, no). If we include quotes around the yes and no values, Looker will output strings and we'll lose the ability to select Hide No's From Visualization:

Screen Shot 2019-03-22 at 9.08.03 AM.png

Screen Shot 2019-03-22 at 9.08.39 AM.png

See how the option doesn't populate in the table calc settings? Now when we remove the quotes and use raw yesno values:

Screen Shot 2019-03-22 at 9.11.06 AM.png

Screen Shot 2019-03-22 at 9.11.20 AM.png

Take note of the purple/pink values! It's how you know you're doing it right.

 

This content is subject to limited support.                

 

 


0 replies

Be the first to reply!

Reply