Knowledge Drop

What causes an "undefined method `getURLs' for #" error when starting Looker


Userlevel 2

Last tested: 
 

This is caused by trying to run Looker version 7.14 or earlier with a newer Java version that isn't supported yet. Make sure the jar is Looker version 7.16+ you're using Java 9+, or downgrade Java to JDK 8

https://docs.looker.com/setup-and-management/on-prem-install/installation?version=7.16

Example full error

NoMethodError: undefined method `getURLs' for #<Java::JdkInternalLoader::ClassLoaders::AppClassLoader:0x58cda03f>

Did you mean? getClass

 

 

This content is subject to limited support.                

 

 


0 replies

Be the first to reply!

Reply