Knowledge Drop

How can I use an apostrophe in a user attribute value?

Userlevel 4

Last Tested: Jan 21, 2019

Just put a \ before the apostrophe!

ex. Default value: O\'Donnell



This content is subject to limited support.                



2 replies

There’s no need to scape for the apostrophe in user attribute values. We can use it as simple as O’Donnell 

I recently ran into this. If you are using Data Type: String Filter (advanced) for your user attribute you cannot escape the ‘

Example if you have multiple user attributes and one has a ‘ in it it won’t work. I tried both escapes \ and ^ before the ‘.
E.g., ‘Client^’s Data 1’,’Client^’s Data 2’  still gives an error or if you try \

The only option was in our ETL to remove any ‘ to turn the attribute in our data from Client’s Data 1 to Clients Data 1