Knowledge Drop

extension: required and validation

  • 15 June 2021
  • 0 replies
  • 9 views

Userlevel 2

Last tested: Apr 30, 2019
 

The extension: required parameter flags an Explore as requiring extension, which means that the Explore cannot be used on its own. The contents and settings of the Explore will only be used when the Explore is extended using the extends parameter in another Explore.

What this means in terms of validation: If there are any validation errors in the base explore then these errors will not surface until the explore is extended and the extended explore inherits the errors. Essentially, there are no errors in the base explore until that explore is extended and we don't resolve the error in the extended explore.

 

This content is subject to limited support.                

 

 

 


0 replies

Be the first to reply!

Reply