Knowledge Drop

Error when starting Looker on a cluster: script start requires at least 0 argument: "script start"


Userlevel 5

Last tested: Aug 26, 2019
 

A user received the follow error when starting Looker on a cluster with the command ./looker start :

"<script> start requires at least 0 argument: "<script> start"." 

We found that the startup flag for --clustered needs to have no value instead "Yes". For example, specify LOOKERARGS="--clustered -d looker-db" to specify to start in clustered mode and use the MySQL backend database specified in the looker-db file.

https://docs.looker.com/setup-and-management/tutorials/clustering#available_startup_flags

https://docs.looker.com/setup-and-management/on-prem-install/looker-startup-options

If you notice other reasons this error comes please add them in the comments

 

This content is subject to limited support.                

 

 


0 replies

Be the first to reply!

Reply