Knowledge Drop

Cannot use non-literal string filter for parameter field


Last tested: May 19, 2020
 

Let's say you have something like this in your LookML:

explore: order_items {

always_filter: {

filters: [parameter_field: "Testing_this"]

}

}

 

We will get an error in the LookML validator because Looker is interpreting the string in the filters expression as the matches(advanced) filter expression syntax. The underscore _ is saying that we should returning anything that begins with Testing and ends with this. This won't work because the parameter can only have one value.

To bypass this problem, we can escape the underscore like “Testing^_this” to get it to read as a literal string instead of filter expression syntax.

 

This content is subject to limited support.                

 

 


0 replies

Be the first to reply!

Reply