Question

Configuring Looker to use Impala JDBC Connector for Cloudera Enterprise

  • 15 April 2017
  • 3 replies
  • 154 views

  • Anonymous
  • 0 replies

In Looker 4.14.10 and later username/password authentication is supported.


3 replies

I have set up exactly as is stated here, but my Kerberized Impala running in Cloudera CDH cannot be connected.

Somehow Looker puts the AuthMech=0 into the connection string even though I explicitly stated AuthMech=1 (Kerberos).


2018-02-19 19:50:50.386 +0000 [INFO|00058|db::4] :: jdbc connect using: jdbc:impala://ip-10-197-28-99.eu-west-1.compute.internal:21050/work;UseNativeQuery=1;AuthMech=0;AuthMech=1;principal=impala/ip-10-197-28-99.eu-west-1.compute.internal@MYREALM.LOCAL

Userlevel 2

Hi @TomasF,


Is this behavior still persisting for you? Also, if you try not explicitly setting AuthMech in additional parameters, are you still seeing this incorrect setting and failure to connect? Please let me know.


Thanks,


Quinn

I was able to set up the connection, dont remember what exactly was the root cause.


This is my working additional params for impersonation:


KrbHostFQDN=.eu-west-1.compute.internal;KrbRealm=;KrbServiceName=impala;DelegationUID={{_user_attributes[‘principal’]}}


Tomas

Reply