Vega-lite not working

  • 6 September 2019
  • 3 replies
  • 375 views

Hi @chasec,


Thanks for giving groodlooker custom viz a shoutout, it looks like it exactly responds to my needs. Unfortunately, I can’t seem to make it work. By that I mean that I seen vega has a possible viz, when I select it, I see the different options, the screen where the viz is supposed to be remains blank.

Anybody with some knowledge on the subject would have an idea of what might cause that?

There’s only some very concise explanation around it so it’s hard figuring out what the issue comes from.


25



3 replies

It looks like Vega just released a couple new major versions, I’m surprised to see a Beta version as the default for the Vega Embed dependencies. It wouldn’t surprise me if there are some breaking changes - I will update the github page with the latest dependency versions I tested (you appear to have it set up correctly).


As for documentation, (when it is working) it is basically just a UI to construct x, y, color, etc as shown in the examples on the vega webpage: https://vega.github.io/vega-lite/


I tried to keep the naming conventions similar!


Hope this helps!

Userlevel 7
Badge +1

cc @ryan.grojean a.k.a Groodlooker who might have an idea or two. You should also pop open the Developer console in your browser and see if there’s any js errors that might have clues.

Is there a general tutorial on how to use vega/vega-lite in Looker?

I found this thread and a few repos, but can’t find how to properly deploy them on our looker.

Reply