Question

issue with field_filter extending an imported dashboard

  • 7 June 2021
  • 7 replies
  • 200 views

I am extending a dashboard from a remote imported project. I have the base dashboard and extended dashboard with the views from the imported project in a new model. I have done no other modifications to the base dashboard; I am testing extends before actually extending something in the dashboard. I get an error when I validate the lookml:

field_filter is using a field outside of the current model ({new model here}). The field "agg_paid_analytics.calendar_type_selector" may not be reachable.

 

This dashboard has no issues with the model from the imported project.

Does anyone know how to fix this?


7 replies

I also just encountered this error. I imported a model / some views from one project into another and added a filter to a visualization based on one of the imported models. Works totally fine with a GUI-built dashboard but when I try to do this with LookML I get the following error: field_filter is using a field outside of the current model (orbit). The field "stargazer.starred_date" may not be reachable.

I’m getting the same issue. Did anyone work out what the cause was? The dashboard works fine as a standard GUI but gives that error when in LookML

I just found this topic and I’ve experienced the same issue. If you can’t use a model parameter in dashboard LookML, how have the rest of you worked around it? I’m trying to make a block that can be reused to that’s why I want to have the constant. 

This typically happens when you have multiple model files in a project. The lookML dashboard tiles or filters that reference an explore from another model file which can’t be accessed.

I think the 2 routes to take are:

  1. Define explores that are used in a dashboard into the model file referenced in your lookml dashboard file. 
  2. Move all explores into a singular model file (may have to update the model parameter in lookML dashboards)

Ok, I figured that out.

Basically, to fix broken imported dashboard you need to make sure that inside model-file you include all views and explores before the dashboards.

In my case, here is a part of my model file:

include: "//views/**/*.view.lkml"
include: "//explores/**/*.explore.lkml"
include: "//dashboards/**/*.dashboard.lookml"

Hope it’ll help.

Following up with this. I’ve also encountered the same problem with an imported dashboard. Anyone have any solutions?

Hi Everyone! 

Do your Dashboard level filters have a model parameter? Looker actually will not scope dashboard field filters to a model parameter. The explores used for these field filters must exist in every model the dashboard is included in. 

I hope that helps! 

Reply