Question

Filtration Works Quite Weird


Hello,



I have problem with the use of filters on when it is used on facts and dimensions. To be explicit, I am going to explain each detail.



I have defined users based on their activity - if they place any order in 0 - 90 days they are active, 91-180 are inactive and +181 are passive. I want to do a basic segmentation where I defined the acquisition brand of the user and the number of orders they placed throughout their lifetime.



I have 2 tables to visualize this:





  1. A table which I list the email addresses in each user type for defined segmentation criteria - 3 tables in total with 1 dimension (Email ID).


  2. Summary table which shows the number of users and their average order value by user type - 1 table with 1 dimension (User Status) and 2 metrics (# Users + AOV).




When I put # Orders for my segmentation criteria, I have no problem with the 1) table. However 2) table is a bit problematic. In example when I want to bring users who have more than 20 orders, 1) table shows me 3 users for Active Users and empty for other users. What I expect from the 2) is to show # Active Users as 3 and the rest as NULL. Instead it is not calculating this on user level which I guess each user group has more than 20 orders and it brings me the all users. I do not understand the logic.



So, I checked everything but couldn’t find a solution for this. Do you have any idea what might go wrong?



edit: Status and Email ID comes from same view.


edit2: When I add Email ID to 2) correct values come into the table.



Thanks


2 replies

Thanks @allegra.

Hey @efeerturk, could you visit help.looker.com with this question, as more questions about your data structure will be required. Thanks!

Reply