Content Validator inconsistency

  • 12 April 2019
  • 6 replies

I’m cleaning up the errors shown by the Content Validator and there is a recurring issue with a measure which I’d previously renamed, and set an alias for. It was ‘count_of_x’ now it’s ‘number_of_x’.

The Content Validator is still showing errors about the field (old name/alias) being unavailable, but when I check the relevant pieces of content they run fine with no errors.

The out of date references are in table calculations (with no error shown when I edit) and custom measures (when I edit there’s no ‘Field to Measure’ selected but the custom measure still works). If I change the references/re-select the field to measure then the content validator errors are gone.

I guess there’s a difference in how errors are surfaced through the content validator and in the UI when queries are actually run as it seems like the alias is working in terms of the queries but not completely working in some sense.

6 replies

Userlevel 7
Badge +1

Yeah, I don’t think content validator necessarily runs all the queries, it just looks for references. I don’t see anything about this yet, so I’ll pass it along to engineering.

Userlevel 7
Badge +1

Simon, can you reproduce this behavior consistently? I realize the word “inconsistent” is in the title haha.

Sorry for the slow reply - just got back from our four day Easter weekend 🐣

I’ve tried to reproduce what I saw by following what I think were the steps that had caused it before - dashboard tiles with table calcs, then renaming and aliasing a referenced field. I wasn’t able to reproduce it though!

A couple of things to note - we actually upgraded to 6.10 today so it’s possible that if there was an issue it was resolved or changed.

Secondly, when I was trying to reproduce and renamed/aliased a (plain count) measure, the LookML validator then complained about the missing field and didn’t appear to respect the alias. In this case it was the count measure from the leads base view of the Fivetran (Redshift) Salesforce block and the errors came from the extended view.

Just for my sanity (and to avoid wasting your time!) I’ve tried referencing the alias in the same view file and it’s not working - and I have screenshots for evidence 🙂

Unless I’m misunderstanding something this doesn’t seem right, and the validator message about timeframes seems odd.

Userlevel 7
Badge +1

A haa. So here, you’re using the alias parameter in the LookML, which shouldn’t be done. Our docs actually say it pretty plainly:

The alias parameter is for keeping URLs functioning and only for keeping URLs functioning, not for lookML model references.

So that one makes sense and isn’t surprising. I couldn’t find anything changed re: the validator, but if it’s working, I won’t question it. Let me know if it happens again and I’ll dig into it further.

oh man 🤦‍♂️

I guess that explains it all then, in my initial question the content was working via URLs whereas the content validator is checking the model references maybe? Anyway I don’t think there’s an issue other than my misunderstanding.

Thanks for your patience. I will remember to RTFM in future 🙃

Userlevel 7
Badge +1

No worries 🙂 It’s a confusing one for sure. Thanks for checking back in!