Using Lookerbot for Slack

Userlevel 5

The content in this post has been updated and moved to the Looker Help Center. Please visit the Using Lookerbot for Slack article for more information about Lookerbot. 


54 replies

Userlevel 5

Cool! Thanks izzy, but I’ve got my hands full with more sought-after other Looker fun, so I’m going to wait for your new integration. I know you guys will do the better job of it anyways 🙂

Userlevel 7
Badge +1

I think you generally cannot restrict Lookerbot access at this time— We’re working on an updated slack integration that’ll have this functionality, and you might be able to tinker with the lookerbot code (it’s open source! to get what you’re after, since I think it’s theoretically possible.

Userlevel 5

Does anyone know of a way to restrict data through this? We’d like to limit lookerbot queries to just our managers, but we have more users than that on our Slack instance.

Userlevel 2

Hi Holger,

Thanks for letting us know the preference. At the moment using wild card would be the only option. We have a feature request to allow the default filtering using “contains”. I have +1 for you.


Thanks - so I have to teach the slack users to use wild cards. My preference would have been to take care of that as part of the Looker Bot or filter configuration. Other options?

Userlevel 3

Hey @Holger_Tamm,

You can use the % character as a wildcard for any number of characters. So you can get “contains ‘x’” by specifying “%x%”, and you can get “starts with ‘x’” by specifying “x%”.

We have the Looker Bot installed at Optimizely and it is working mostly great.

One question though: Are all filter parameters always passed with operator “is”? We would like to use “contains” or “starts with”.

Userlevel 6

hi, since we installed chromium and turned on the labs feature for enhanced rendering and enhanced vis, sending lookerbot pdfs directly into slack seem to be corrupted (they open with the broken image icon). If i download the pdf from slack and open the error message is:

Adobe could not open “yourpdf.pdf” because it is not a supported file type or because the file has been damaged

we have not seen any other issues with these lab features so far.

any ideas!?

Userlevel 2

Hi @IanT,

Expanding Looker URLS is not available in Direct Messages due to the distinction made between private/public channels and direct messages in the legacy unfurling API capabilities used in Lookerbot. However, I can let the Lookerbot team know you’d like to be able to expand links in DMs. If you have any further questions, please feel free to reach out to us at

Userlevel 6

Expanding Looker URLs - why does this not work in direct messages to the lookerbot. We have it working in channels that the bot is in and I got asked why not in PM’s, I couldn’t give an answer.

Userlevel 2

Hi @jwdeitch,

The steps outlined in the lookerbot repo linked above do represent most up to date process for installing Lookerbot (Heroku specifically is the recommended approach for deployment and provisioning your server). However, you may be interested in the Slack integration of the Looker Action Hub. Once this integration is enabled in the Admin --> Actions panel, you can schedule Looker content directly to slack as an attachment. The process for sending data to Slack using this feature is outlined here. If you have any further questions about enabling this set up, please visit us at!

Userlevel 1

Hi there,

Is there any chance we can setup a slackbot without having to configure deployments, updates, servers, etc?

I just wanted to give the community a feedback on this one.

The “issue” in our case is that Looker id permissions are not fully clarified on the tutorial and we missed thinking on this point early.

The id that is acessing Looker has to have the privileges to download images from the looks (obviously, but not that clear through the tutorial). We found that by giving all privileges and then removing one by one.


Userlevel 2

Hey @Febonza,

Looks like your colleague Lucas has reached out to support about this error and is working with our team to resolve! If you have any further questions feel free to visit us at

Hello @IanT,

We actually recommend to take a look on the Looker logs for that, I am expecting the error to show up in there.

We use Sublime here mainly (Mac).

Just please go ahead and send them to, we will be glad to investigate this further and try to find out the culprit.


Userlevel 6

We host the bot ourselves and would like to get at some of the log files for the bot to see whats going on but I don’t know where to look (should I actually just be looking at the looker log files instead - you recommend a good log file viewer)? We have a handful of looks that when you schedule them to slack they display the same error as the above poster - “An error has occured”. If I change the look to a table viz then its fine. We have plenty of other looks scheduled to slack that work fine (upload the image to GCP and displays in slack).

We have been trying to successfully setup lookerbot in our company. We were able to retrieve data that are plain text fine, but when we try to retrieve images, nothing happens, sometimes it gives an error after many minutes and its a generic one like “An error has occurred”.

I was not able to find any log messages, I tried to start yarn in dev mode but I think the issue is not on yarn level.

We tried using Google Cloud bucket as well as S3 buckets but we had no success on both of them. The files are not being uploaded to the buckets.

Can someone help me to setup a debug mode so I can at least see whats going wrong?



Userlevel 2

Hi Svante,

Is the /looker help command working for you? If not please come on chat and we can troubleshoot it from there for you.

Thanks 🙂

About those Slash Commands, we can’t get that part to work. When I try in Slack I get this:

slackbot [2:16 PM]

Darn - that slash command didn’t work (error message: Failure when receiving data from the peer). Manage the command at Looker.

When I type '@lookerbot test db b I do get a nice graph so that part is working.

Anyone have some idea why the Slash Commands won’t work.


It’s fine now, I found out where to look in the logs, I was having connection errors. @looker help is working for me now.

Hi Mike,

Can you show me what is the slackbot reply that you get when trying @looker help? I’d suggest that you come on chat (chat support), or email us to so we can further troubleshoot this issue in more detail with you.

Ok, I tried that /looker. I just got:

/looker is not a valid command. In Slack, all messages that start with the “/” character are interpreted as commands.

Does that mean I didn’t set something up right? I thought slash commands were optional?

How do I get @looker help to work? I see in the git repo’s instructions that I should do @looker help to verify it’s working. Also says re: Slash Commands:

Slash commands are not required to interact with the bot. You can DM the bot directly or mention the bot like:

@looker help

and use all the functionality.

Hi Mike,

I noticed that you are using @looker help, to actually invoke the bot you can use /looker help. Give that a try and let me know how it goes 🙂

I just installed the lookerbot on an instance in Google Cloud engine. Looks like it running:

Nov 12 22:24:12 looker-slack-bot yarn[10265]: yarn run v1.3.2
Nov 12 22:24:13 looker-slack-bot yarn[10265]: $ ./node_modules/.bin/ts-node ./lib/index.ts
Nov 12 22:25:09 looker-slack-bot yarn[10265]: Using Looker information specified in individual environment variables.

But in Slack when I type @looker help I get the slackbot reply. How do I troubleshoot why it’s not working?

I just deployed Lookerbot through Heroku and integrated it with my company’s Slack domain. However, I am getting an out of date error in Slack when I try to do a Lookerbot command.

Is it possible that this issue noted in Github is the source of the problem?