Google BigQuery Connection - Error

Has anyone else had errors when connecting to Google BigQuery. When I test my connection, I get an error saying: “Driver cannot be found: undefined local variable or method `e’ for #Looker::DBConnectionTester:0x12ce1da0

Just wondering if anyone else is getting this error. I’ve never seen this before, so I am not sure how to fix it.


13 replies

Userlevel 4

did you configure pdt?

do you disable autocommit in bigquerry?

try to add (depends to your syntax) AUTOCOMMIT=TRUEin your JDBC Line in your connection in looker


Yes, the PDT box is checked.

I also added that statement into the JDBC field and I am still getting the same error

Userlevel 4


we had the same issue with snowflake.

I added “…&warehouse=PRODUCTION_IBI_WH&AUTOCOMMIT=TRUE” to the Additional Params because we disabled autocommit in snowflake.

Have you tested different spellings.

Snowflake was case sensitive

Userlevel 4

but you could test it.

if you loggin to bigguery. for sure you will have a “query viewer” where you can see all running and successed querries, or?

to be on the safe side delete the “CONNECTION_REG_R3 table”

then go to this viewer

other screen: run the test connection in looker

locker now will recreate the table and insert dummy records.

in you viewer you should see the insert of 1 row

after that, looker selects this table.

If the select is empty. you should have the same issue, i had.

If looker can select this one row, the issue is on a other place

I have tried that and different combinations and still no success yet.

Userlevel 4

Have you deleted the CONNECTION_REG_R3 table?

Was looker able to recreate it?

Was looker able to insert into this table?

Was looker able to select then the insertet record?

And could you try, what happen if you disable pdt in your connection?

I deleted the connection_reg_r3 table. When I tested the connection, it looks like looker was able to recreate this table. Then did nothing and leaves it empty. This is when the error message comes up in the Looker connection.

Userlevel 4

Exactly same behavior I had

Could you check if autocommit ist enabled or disabled in your bigquerry enviroment?

It is enabled. I tried both, enabled and disabled and still no luck

Userlevel 4


then I’m sorry. “My” solution won’t solve “your” problem. Sorry!

But I still think it’s the right approach.

It was the same with us. It always worked, until -eventually- a release changed something.

For us it was the commit problem, maybe it’s the same for you.

Have you ever tried to delete the connection, delete all the tables created by looker, then re-connect without doing PDT, and if that works, then reconfigure PDT. ??

Otherwise: The looker support is great!

They will help you.

Hey @niccolee and @moebe!

This turns out is a new Looker side issue we have discovered recently, there is nothing you’ll be able to do on your part to fix this error message from arising. But we’ve already gotten it reproduced and have engineers actively working to fix it.

Thanks for your patience with it! And feel free to reach out to support to ask about updates.


Have there been any updates with this issue?

Userlevel 7
Badge +1

Not yet Nicole, we’ll update the thread when the fix is released. We’re reviewing it right now.