Question

Chrome : Error 401 - not authenticated while accessing looker URLs

  • 13 August 2020
  • 7 replies
  • 1579 views

Hello,


We are unable to view looker reports with latest chrome’s SameSite Cookie updates from google as per this https://www.chromium.org/updates/same-site


Works fine with other browsers like firefox


More can be found in this screenshot


I’m assuming Looker team is already aware of this release from Google and are working on setting cookies with SameSite= None?


Thanks


7 replies

Userlevel 7
Badge +1

I believe we are already working on figuring out how to better set cookies to cope with the increasingly anti-cookie world, yes. But this is specifically for an embedded case, right? I wouldn’t expect to be seeing this in just the standard in-app Looker experience.


There’s a few things potentially at play here, and it’s possible I’m barking up the wrong tree and it’s all related to the chrome updates but… Are you hosting your Looker yourself? If so, are you using --no-ssl? That can cause these problems and i noticed the warning references a non https looker url.


Also, these kinds of cookie issues pop up in safari also and are hard to swat. The best move will always be to get your Looker set up on a custom domain so that it’s not third-party on the site it’s being embedded on.


And just out of curiosity… What is the value of the looker.sameSite cookie there?

Hey,


I am in touch with looker support and will keep you posted here once we find out the issue.


Thanks.

Userlevel 6
Badge

any news with this? It was working for me until I updated chrome.

Thanks!

Hey Ian,


We are using –no-ssl start up flag when running our own looker instance, but the support team advised us to use –ssl-provided-externally-by and try out.


This is yet to be tested by us.


Meanwhile you could try this out and access looker in chrome



I guess, its best to set them to default after accessing looker.


Thanks

Hey Saivivek,


Did you end up trying the –ssl-provided-externally-by method?

Thanks

Hello Alon,


we have tested this –ssl-provided-externally-by startup flag on our dev environment just now and we are able to see reports with out any problems.


Although we have yet to test this in QA and PROD, I guess this change should work there too.


@izzy,

For your questions, below are the answers

Our looker instances are “self hosted” (on Linux VM clusters on Azure) and we are using 6.24.72 version


Yes, we are using --no-ssl flag and also we use a custom DNS domain something like this [https://{env}-looker.xy-xyz-test.com] env stands for diff envs like dev/QA


And the looker.sameSite cookie value is in this image


Thanks,

@izzy @IanT I am running into the same issue so could you please help me with this

 

 

Reply