Solved

"Validation Failed" when I try to edit my database connections

  • 8 June 2022
  • 4 replies
  • 199 views

Hi everyone,

We connected Looker with BigQuery and everything is working fine. Now we need to update the JSON key of the Service Account we use for Looker. The process is described here: https://docs.looker.com/setup-and-management/database-config/google-bigquery. Actually, we already have the connection, so we just need to click “Edit” and upload the new key.

 

However, when we do that and we click “Test” to test the connection, we receive a “Validation Failed” error, with no other information 😥.

 

Do you have any idea of what the problem could be?

Thanks.

icon

Best answer by Yisus 14 June 2022, 15:46

View original

4 replies

We are experiencing the same thing running Hosted Looker with an Athena connection. No problem for 1.5 years with regular edits to the connection but all of a sudden “Validation failed” when Testing new changes. Saving the connection with the new changes will just put you back to the Connection list without the changes being saved.

Having the same issue generating any BigQuery connection on our instance. Service account permisions are fine (even tested with owner) and OAuth connection gives the same error

Answering again since I can not update my previous post.

Disabling “New Add Connections Page” under Admin > Labs did it for us. Looks like this experimental feature might be bugged.

 

Thank you @Yisus! It worked for us too 👍🏻

Apart from this issue, I think that the old “Add Connection Page” is also more complete and intuitive. I hope the Looker team will try to make some adjustments.

Reply