Question

Looker can not start because: Unable to initialize the keystore.  Please check your environment.  [Invalid keystore options]


Brand new installation of version 22.8.39 running with: start --no-daemonize --no-log-to-file --no-ssl

2022-06-06 17:08:12.634 +0000 [INFO|007e4|crypt] :: Initializing GCM Encryption
2022-06-06 17:08:12.637 +0000 [FATAL|007e4|crypt] :: Unable to initialize the keystore.  [Invalid keystore options]
2022-06-06 17:08:12.644 +0000 [ERROR|007e4|encryption_keyset] :: Unable to initialize the keystore.  Please check your environment.  [Invalid keystore options]
lLooker can not start because: Unable to initialize the keystore.  Please check your environment.  [Invalid keystore options]
l2022-06-06 17:08:12.648 +0000 [WARN|007e4|ruby:stderr] :: Looker can not start because: Unable to initialize the keystore.  Please check your environment.  [Invalid keystore options]
2022-06-06 17:08:12.650 +0000 [ERROR|007e4|crypt] :: Unable to initialize the keystore.  Please check your environment.  [Invalid keystore options]

 

I believe this started with 22.8. How do I disable the keystore? We’re not using SSL.


2 replies

Hi  Mconigliaro,

 

Please check if you have GCM encryption key environmental variable maintained or not.

eg:

LKR_MASTER_KEY_FILE

or

LKR_MASTER_KEY_ENV

Regards

Pratap

 

Hi  Mconigliaro,

I updated the “/etc/systemd/system/looker.service” file with the GCM encryption key file at Service section.

[Service]
Environment="LKR_MASTER_KEY_FILE=<pathtoencryptionfile"

After the above update 

systemctl daemon-reload
systemctl enable looker.service

systemctl start looker

 

Regards,

Pratap

Reply