Question

How to set "is between [inclusive]" instead of "is between [right-exclusive) in drilldown?


I am using simple histogram chart and drilling down from a histogram column (for example, Account count in x-axis and territory count in y-axis). It takes all the filters and passes to drilled charts (which is good so far). But one of the filter(which is on account count) is put as "is between [right-exclusive)". Because of this the result does not match. But if it would have put as "is between [inclusive]" then the results match. How do I tell the "drill into option" to use [inclusive] instead of [right-exclusive)?
 


2 replies

Userlevel 2

Hi Dev_Rana!

 

Your description is right, that is the looker behavior expected.

 

Did you try  creating a new date dimension based on the original date and  adding +1 day in the dimension ?

 

Best!

Leo

 

 

Hi Leo, thanks for your reply. But looking further into this issue, I see that the issue is with “histogram” visual control that is available in looker marketplace. The issue is as follows:

  • If let’s say there are 5 territories having the account count of 350 and another 6 territories having count as 400 then the 300-400 histogram column shows 5 and 400-500 histogram column shows 6. And so, the drilldown having [right-exclusive) is correct.
  • But for the last histogram column, the above rule does not apply. Meaning, if there are 20 territories having count as 1900 then it shows 20 in 1800-1900 column. But as per above rule, it should have shown 20 in 1900-2000 column. This is the reason why that drill-into is  not matching the result.

Is there any setting in this histogram visual chart so that the last column also follows the same  rule as other column?

Not sure of your suggestion of creating a new date dimension. How does it relate here?

Reply