Looker seeing IE11 as IE10?

  • 30 January 2017
  • 0 replies

I’m trying to get Looker to work in IE11, but failing. It displays an error page advising to upgrade, but I’m already on 11. We’ve got a locally-hosted instance of Looker, just updated to the new version last Friday. I use PHP for scripting to generate the URLs.

I’ve tried 3 different ways to get Looker to display in IE.

  1. Generating the URL to the local Looker instance on the landing page, then doing a on a link pointing to that URL.

  2. I’ve tried doing on a link pointing to a page that would then generate the URL and do a header redirect to it.

  3. And I’ve tried loading the URL in a hidden div on the landing page that can then be toggled by clicking a button.

So far, IE only likes the first option, but the problem is the nonce value expires if you leave the page alone too long, or you close the popup and then click the link to open it again. I guess my last option is to somehow create the URL when you click a button but not involve redirecting in the popup window.

I’ve no idea why the other two things fail, but they do so in different ways. The popup that does the redirect fails because it thinks my IE11 is IE10, as shown. And the hidden div option just displays the Looker login screen.

I don’t have compatibility view turned on or any sort of agent-setting values. I’ve got security turned down to accept all cookies, and my website is in the Trusted Sites list.

These all work in Chrome, but it’s a requirement to get this working in IE as well. Can anyone advise some alternate method to get Looker to display reliably?

0 replies

Be the first to reply!