Table-next not saving column order in looks or dashboards

  • 4 December 2019
  • 2 replies

I’m having an issue with table-next visualizations in a dashboard.

I’m using subtotals for two dimensions: District & Store

When I open the table in the edit window, District is correctly to the left of Store.

But when I close or save the edit window, District is moved all the way to the right.

Display in edit window (‘Save’ button is disabled):

District is correctly the 1st column & Store name is correctly the 2nd column

Display in dashboard:

District is now moved all the way to the right

If I move District all the way to the left in the dashboard view, it’s all good, but when I refresh the page it goes back to its incorrect spot all the way to the right.

Can anyone help? How do I get the “District” column to stay in the correct spot?

2 replies

Hi everyone, Do we know if there was resolution on this? I have several dashboards with multiple columns and no matter what process I follow, the column order never saves. I am using Totals at the bottom, dimension columns, and calculation columns. The order of the columns is necessary as some of the calc columns compare columns early in the viz.

Just finished chatting with Looker support. They said this is an engineering issue related to the use of the subtotals option in the table-next visualization. No workaround yet