Jank Workaround: Edit font size in single value vis

  • 28 May 2021
  • 1 reply
  • 78 views

Userlevel 3

I’ll forwarn, this is exceptionally jank and is a bit finicky, but it should work with just about any data and doesn’t require HTML. It also could potentially break at some point, but probably only when visualizations are completely reworked (which would solve this problem most likely). That disclaimer aside, the workaround: 

1 - Starting Point

For example’s sake, I’m starting with a really simple table like this: 

Note: It doesn’t have to be this simple, the hack itself doesn’t really care about the table’s complexity. The important part though (as we will see in a moment) is that there needs to be only one row and measure column shown in the vis. 

2 - Change vis type to `ScatterPlot` and open the vis settings menu

You should now be here: 

Yes, scatterplot I know. I forewarned this was going to be jank. 

3 - Edit vis settings

You’ll want to make the following changes: 

  • in “X” tab: 
    • Toggle OFF “Show Axis Name”
    • Toggle OFF “Axis Value Labels”
  • in “Y” tab:
    • Toggle OFF “Show Axis Name”
    • Toggle OFF “Show Axis Values”
    • Toggle OFF “Gridlines”
    • Make note of the “Minimum Value” and “Maximum Value” fields at the bottom, we may need them later. 
  • in “Series” tab:
    • Edit color of series in Customizations > Series name, toggle to “Custom”, and replace the color code with “white”

       

  • in “Values” tab:
    • Toggle ON “Value Labels”
    • Input a color into the “Value Colors” field

 

Your vis should now look something like this: 

4 - Tune to your preference

From here, you can control the text size with the “Font Size” field, and formatting with the “Value Format” field. For ex, selecting 100 in “Font Size” renders this: 

Depending on the value you’re displaying (as is pictured here), the text may not quite be centered. To resolve that, we’ll want to go back to the “Y” menu and change the min/max value settings. I’ve found that a Min value just under and a Max value of just over the value we’re displaying usually centers the vis quite nicely, like so:

 

And that’s the hack!


1 reply

Is there a hack to show the text at the bottom darker than what it shows? i am using a single value look.

Any help is appreciated. 

Somehow the title shows opaque with 30-50% transparency i believe, i hope there is an easier way to fix this.

 

Reply