Question

I see a warning: ["view_name.field name" no longer exists on explore_name, and will be ignored], what happened?

  • 16 April 2021
  • 5 replies
  • 40 views

I’ve found a couple of articles about this, but none of them help.

 

Looking at a Look, I’ve got that a field name no longer exists, but the report is running, showing that field, and correctly filtering on that field.

To get to the report, I used the link from the Schedule History where it’s failing, which means the address has a bunch of characters after the 4 digit Look number. If I remove those additional characters the report runs fine without the error (showing the same results as with the error)

 

Yesterday due to this I deleted the schedule, checked I was on the version that worked fine and set up another schedule. Today on checking, I’m getting the same error on a different field.

 

Is there something in the scheduled version of a Look I need to change or look at to get this to work? Because when looking at it, you can ignore the error (since it works), but when it comes to the schedule it’s failing.


5 replies

I would edit the look, until you don’t see any errors in the look itself.  It may appear to be fine, but the field name in the error is not affecting any filters in the look and cannot be used as a dimension or measure (it is not available anymore to the data model/query causing the error).  Usually, someone changed the field name in the LookML view or removed the field altogether. Once the look is error free, save it and you should be able to create a new schedule that runs.

It’s being used in the filter and shown as a dimension, it’s working fine, despite the error showing.

The field hasn’t changed in the LookML, or in the underlining SQL.

Here is a more detailed explanation, with some other reasons you might be seeing the error: 

 

I know you say it’s working as a filter and dimension, but that should not be possible as that error indicates the field is not available to the query. Also, check your SQL in the data area and search for that view_name.field_name.

Not sure how much I want to show of the names of things, but here is the report.

The top image is the link from the schedule history, showing the report didn’t run because of the error.

I can see that the filter has worked fine, the field is the last one, on the right, and it’s showing the 4 rows that match the filter. The field isn’t missing.

The second image, all I’ve done is remove from the address anything after the look number (4881) and run it again (even clearing the cache) and it runs without the error, and shows the exact same results.

When I go into the LookML everything looks fine, the same as when I initially put it there, the same for the SQL views it’s linked to, so I don’t know what I’m supposed to change it to

It might be a bug.  I would contact Looker support and they should be able to assist.

https://help.looker.com/hc/en-us/requests/new?ticket_form_id=34884

 

Reply