How do you use the Trellis charts?

  • 30 April 2019
  • 3 replies

Userlevel 1

I currently have 4 charts showing stacked data of categories, with the X axis being time, the category is a pivoted dimension.

The 4 charts have the same filters, with 1 dimension filter being different for each chart.

I figured with Trellis charts I could have this as 1 look rather than 4, which could expand to 5 or 6 as new things are added instead of needing additional work.

I went into the explore of the chart, removed the filter and added it as a pivot and changed the visualisation to a Grid Layout By Pivot. The visualisation now says “Max grid size is 12. Reduce Pivots with column limit or change Grid By to “none”.”

I’m guessing I need to add some subtotals or something to the data to get this to work? Or check some other option somewhere?

3 replies

Userlevel 7
Badge +1

It sounds like your filter dimension has more than 12 values— Could you try also adding a filter to it to just get the 4 values you were after? You could also try adding a column limit, per the error message.

Userlevel 1

My trouble is that I’ve got stacked data, so once I pivot the filter it doesn’t work. I don’t know if I can only have 1 pivot, or I need to do something else. I’ve made some examples here rather than using what I’m actually doing since I’m not sure about posting pictures of actual names.

Visualisation showing the volume of calls per hour, stacked with an RPC flag:

But I want to get this as 7 (or less I suppose) different charts, one for each day of the week, so ideally I’d use Trellis to get that split rather than copying the chart 6 times for the dashboard.

If I limit the columns to 12, it displays something

I had to put this into a dashboard and make it really long, and I can see that it’s 12 graphs, I’ve completely lost the stacking on the 0/1/null so graph 1 is 0-Monday, and graph 2 is 0-Tuesday until it wraps round to 1-Monday.

I tried saving 3 and 4 “Graphs per row” to get a better picture, but that didn’t seem to change anything, and the graphs seem to have a fixed height, so in a Look all I can see are the first two graphs, it’s only on a Dashboard I could see more.

But the main problem is that I still want to stack the RPC variable (0/1/null) and only split the graphs by day

Hi @izzy I am facing similar issue. Is there any update on this request?