Drill Down Option Stopped Working in Dashboards: Unexpected end of JSON input

  • 1 September 2022
  • 16 replies

Userlevel 1

Hello, we have an issue which seems to have appeared without any changes from our end. Drill down options display the Unexpected end of JSON input error in the drill down pop up. All of these drill downs were working fine before.



Any idea what causes this issue?


Best answer by Tom Roberts 6 September 2022, 16:22

View original

16 replies

Getting same error. Can someone help me with it?


Seeing the same issue.

same issue, did anyone find the solution?

Userlevel 1

One way around this seems to be clicking ‘Explore from Here’ in the drill down window where you see the error. The explore layer opens and you can see the drilled down data.


I cannot comprehend why it does not render directly in dashboards. Can someone from Looker staff take a look?

@vsil  -- thank you. I saw that too, however, not everyone has Explore rights in our company, and they need to see the dashboard in question drilled down :(


Having same issue, please advise.

Same thing has happened to our instance. Enabling the legacy runtime again fixed it for most existing tables. Admin > Legacy Features and you can toggle it on from there. However I still get the error when creating new visuals sometimes.

Same issue here.

Userlevel 1

Thanks @Tom Roberts, turning on the Legacy LookML Runtime solved this issue. Hopefully Looker will come up with a permanent solution as this one is valid only for the next 7 months.

Thanks @Tom Roberts, it worked here too. Waiting for a permanent solution, because activating the Legacy LookML Runtime can impact on queries performances. 

I am also having this issue, why is this issue marked as resolved?

Ran into this issue today for the first time. Activating the Legacy LookML Runtime worked for me for now but prefer this not be the fix.

Userlevel 2

Not working for me and I already have the Legacy LookML Runtime activated

Not working here either. Seems to work sometimes, but not others. Is anybody looking at this?

Does anyone know if there is a bug report for this that I can upvote? 

Works when enabling the legacy runtime, but there is a disclaimer saying that this setting will be removed in a few months.

Can we please have a fix?

Many thanks