Question

Dashboard Visualisation not Updating after Editing Tile

  • 20 December 2019
  • 10 replies
  • 630 views

Userlevel 3

Hi


Has anyone else had the issue, where you edit a tile on a dashboard, then change the type of graph from say, a table to a stacked bar chart. Then when you save it, the dashboard does not update to the specified visualisation? If I click edit again, and the look opens up, it shows the correct visualisation on the edit screen. But then again, when you save or close it, it shows the incorrect visualisation on the dashboard.


~GD


10 replies

Yes, I’m having this issue as well! Thanks for posting.

I am having the same issue.

Userlevel 3

I got word from Looker that they are looking into it.

I’ve been scouring the internet. No help. “Duplicating” the tile , “Clear Cache and refresh” don’t work.


The quickest workaround I have discovered is to:



  1. Select the “edit” tile option to open the editor

  2. From within the editor click “Explore from here” to replicate the view in a new explore window

  3. From within the new explore window click the gear and select “Save to dashboard”

  4. Choose the appropriate dashboard. Navigate to that dashboard and refresh. The new tile should be in place with the correct visualization.

  5. Fix the title and reapply any dashboard level filters as previously done.

  6. Cleanup by deleting the old tile and rearranging as desired


Hope this helps. If anyone has found a better way I’d love to know. 🙂

We’re still experiencing these issues. Has this actually be resolved?

The above was helpful to resolve for a one off but this is afecting more than one dashboard!

Hi ! I’m getting the same issue - the only fix I’ve found is to delete the look and re-add it to the dashboard.


Any news on if/when this will be fixed ?


Cheers,


Richard

I am also facing the same issues, trying to update filters on a dashboard but not reflecting after save. This is long persisted issue and very basic thing, still no solution which is really frustrating

With the help of the great Looker support I found what was causing my looks to be different in the Look and Dashboard.


I had the same field in both the Look and the Dashboard filter. i.e.


    Look : field1 <> "X"
Dashboard : field1 = is any value

The dashboard filter takes precedence hence the difference. My initial fix (though not sure how elegant/efficient it is) was to create a duplicate view just for the Look filtering since I didn’t want the Look filter showing to the user.

Userlevel 3

hi @worthywow - this is a different issue though.

This is for example, you have a bar chart. Then you edit the tile and change it to a line chart. Then when you click save and go back to the dashboard, it still shows as a bar chart.

still no solve????

Reply