Dash rows cut off when sent to Slack

  • 18 February 2019
  • 4 replies

Hi all,

I have created a dashboard that is a table of customer accounts with various bits of data in each row and would love to share with my org via Slack. However, I have tried all of the options I could find (pdf, visualization, changing the paper size, as well as sharing the Look directly) and none of these will return the full table. I’m currently only able to get around ~30 rows to display out of a total of 62.

Would love any advice so we can actually disseminate our work!

4 replies

Userlevel 3

This is odd, does the full table display when you created the Look via an explore? Does it show up when you open up the Look?

There are a number of reasons you could be getting less rows than you expect:

  • data table row limit: on each explore this is defaulted to 500 so I’d be surprised

  • table viz row limit: in the table edit options you can limit the number of rows shown in the Viz (note the Table viz (‘Visualization’ panel) is different to the data table (‘Data’ panel))

  • filters: are there any filters being applied that are removing your data points?

  • grouping: Looker applies a ‘group by’ to every dimension selected, which means you only get back the unique combinations of the different dimensions returned into the data table. This means that even if you have 60+ rows in the source table, you might only have 30 unique combinations of the dimensions you’ve selected.

If you could give any supporting examples it would be great to help diagnose you further. For instance could you show us where you see the full 62 rows, where you see only 30 rows, and what steps you go through to get from where you see 62, to where you see 30.



Hi Andy,

Thanks for the reply, let me try to be more thorough.

The dashboard consists of 2 looks, a chart at the top (aggregate NPS over time) and a table of ~60 odd rows with accounts and various fields associated with each.

It displays fine in Dashboard format (though you have to scroll quite a bit to see all rows). It also works fine when the table is viewed individually as a Look.

I have not set up ‘Limit displayed rows’ in the Look or the Dash, nor have I changed any filter settings between the Dash/Look and my attempts to export, and neither have I used a ‘group by’ function.

For all Looker-based operations, the Dash is working just fine. It’s only when I try to Send to Slack or Email as either a pdf OR a visualization that the table is cut off to 32 rows.

I’ve tried multiple page formats and layouts (e.g. Landscape vs. portrait, standard v. legal v. A0/1/2) as well to no avail. It just seems the export function is limited to the equivalent of one page, so when this table extends beyond that scope, it gets cut off.

It DOES seem to work only if I go to the Look and export via email as a Data Table, but that doesn’t really solve my use case of setting up a repeating send in Slack!

Any thoughts would be much appreciated!


Userlevel 4

This is actually a feature in the upcoming release 6.6: Looker 6.6 Release Notes

Excellent - thanks, Brecht!