Question

Custom Reference Line appearing on Wrong Axis

  • 22 September 2020
  • 8 replies
  • 426 views

Hi,


I am trying to put a Custom reference line on a visualization but it keeps putting it on the right axis even when I’ve selected the left axis.


Is this a bug or am I doing something wrong


8 replies

Same issue here.

Same here. I have a left and a right Y axis and the reference line (type “line” and with value “custom”) always positions the line based on the units of the right axis. 

Hi @Kamani_Charles ,

 

A reference line won't be explicitly assigned to the left-hand or right-hand axis on its own. The left/right axis labels in the screenshot below apply only to the “Configure axes” section and not the “Markings” section where we define reference lines.

Does this screenshot look similar to your settings menu?

 

Instead, reference lines are applied to the first measure in your table (whether it is hidden from visualisation or not). So if your first measure is on the right-hand axis then your reference line will also be based on the right-hand axis, even if it’s a hardcoded number.

If you ensure that the measure on your left-hand axis is the first measure in your table this should solve the issue.

 

Please let me know how it goes, or if you have any questions on this.

 

Best wishes,

Shaan

Worked for me! 
Quite confusing though :D

Thanks

Great! Glad it worked.

Okey... So what should I do if my second measure is a table calculation?

Ditto to @aurimas ‘s question…. I want to create a reference line based on a table calculation. It doesn’t appear this is possible. 

 

For example, I often have a bar graph with a count measure, and then create a table calculation to show the % of total of a certain category. Then I want a reference line to show what the target % is, but as far as I can tell, I can’t do this. 

I have exactly the same issue as mhayward.  Am I forced to generate the table calculation as a measure in the model in order to accomplish this?  

 

Another hack I just tried, and seems to work:  set up “dummy” table calculations for the measures that were in the model, and use those in the viz.  What a pain!

Reply